Partial outage impacting Visa Debit processing

Incident Report for Poynt Services Uptime Status Page

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 09:05 PDT

Identified

The issue has been identified, and a fix is being implemented. Transactions can be processed as credit as a workaround.
Posted Apr 11, 2025 - 08:25 PDT
This incident affected: Payment Processing Availability Services.